Confluence - Error You must first lock the file aaa.xlsx before it can be edited - any idea what that means?

Hi, I am trying to attach an excel sheet to a Confluence page and it says ‘You must first lock the file aaa.xlsx before it can be edited’, aaa.xlsx being the name of the file that I am trying to attach.

Do you have any idea what it could be? Not working with any apps or macros or anything, just pure attachments.


Is this a re-load of the attachment? Was the same file or a file with the same name already attached to your page?

This error is usually given when attempting to upload an attachment by the same name. It’s as if the attachment is still present, but not visible on the list; the file must be renamed or uploaded in a different location to work around the issue.

Could you try that and see if it solves the problem, please.

In general, you can find all info about attachments (even so not about this issue) starting from this page of Atlassian’s Confluence documentation.

Please also check out our Video Tutorial Series “Learn Atlassian Confluence”.

I renamed the file and it worked. Thanks so much! I really appreciate the help.

I strongly feel it should be improved, the warning message is also not meaningful.

Great, I am glad it worked for you. And I agree. Atlassian is already aware of the issue and I guess, working on it.